技術

wordpressのpluginをアップデートしたらエラーが出たよ

Pocket

PHP5.3のままWordpressを運用していたら、Pluguinのアップデートでエラーが出た話。

利用している「Related post plugin」というプラグインで
Arrayを[] (square brackets)で記述している部分があるため(この書き方はPHP 5.4以上じゃないとサポートしていない)
5.3の環境で構文エラーとなった。
5.3に固執していた訳ではないので、サーバーのPHPをバージョンアップする事で今回のエラーは解消された。

現在、Wordpressの稼働推奨環境としてはPHP 7以上となってはいるが
一応はPHP 5.2.4 以上、かつ MySQL 5.0で動作する、となっている以上
もし自分がプラグインの作成する時は気をつけようと思った。

Pocket

mm

作成者: ぴーやま

なんとかエンジニア。忘れっぽいのでブログにメモをしている。
最近、一番好きな食べ物は汁物に浮いているたまごなんじゃないかなぁと思ってきた。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です